PDA

View Full Version : King's Bounty: Armored Princess issue


metiu
11-05-2009, 08:34 PM
Hello

I've got big problem with KB: Armored Princess. During the play game suddenly freezes for few seconds (scene is cut with multiple colorful diagonal short stripes) and then all graphic is switching off (game is working, cursor is on screen, I can move/cast spells, but all scene is black - and not only in the game, but also in menu (Princess is visible but everything behind her is black)). After I quit to desktop there is an exclamation mark in my tray, but I can't open it. I thought it was hardware error, but I tested my hardware and everything is working just fine. What's more irritating - exclamation mark is not turning off until I restart my computer (even logging off is not working). This error isn't regular, but happens randomly.This kind of bugs doesn't appear in other games. What is happening?

My computer:
Windows Vista SP2 (with all possible updates)
Core 2 Duo 2,6 GHz
4GB RAM
ATI HD 4850 512 MB

Best regards
Mateusz

Edit: One more thing. Exclamation mark is affecting also on Windows Vista also. After quiting game - if UAC is asking for some permission, my monitor is showing monolithic colorful image which is disappearing after I cancel UAC (press ESC).

Elwin
11-05-2009, 08:52 PM
Language version? System x86 or x64?

jake21
11-05-2009, 08:55 PM
I had this problem with king bounty when I updated graphics card drivers. It had something to do with cached textures and I had to delete them. I forget now where the textures were cached but perhaps that will give you a hint...

metiu
11-05-2009, 10:04 PM
Language version? System x86 or x64?

Polish, x86.

jake21

I will look for them - thx.

Sorry didn't find them - any clue what else can I do?

RonTurbo
06-10-2010, 03:02 PM
Many months since thread was started. Any answers? Cause I have this problem right now. Screen goes black, but game is running in the background.
If I restart the game the black screen is there from the start.

Great game, but no more 1C games for me if significant bugs like this never get fixed.
__
Windows XP SP3
Intel Core2Duo E6750
nVidia Geforce 8800 GTS
4GB RAM
Game is running through Steam

N3MES1S
06-10-2010, 08:42 PM
Hmm, have u tried to run the game with administrator rights? do u have any problem with other games? have u checked that all the d3d libraries are ok (running the dxdiag)? have u tried to modify the game settings on the /data/game.ini file? maybe is something with the refresh rate, try to change it manually on the game.ini file..