View Single Post
  #1  
Old 11-19-2015, 11:06 PM
eternalyouth74 eternalyouth74 is offline
 
Join Date: Nov 2015
Posts: 1
Default Crossworlds patch question

I bought a twin pack that has both Armored Princess and Crossworlds. As far as updating do I just need to get the 1.31 patch? If I am not mistaken just having Crossworlds means the Armored Princess campaign is updated and I wouldn't need a separate patch for that I assume?
Reply With Quote