View Single Post
  #9  
Old 06-14-2019, 06:13 PM
Tennie Tennie is offline
Approved Member
 
Join Date: Feb 2015
Posts: 13
Default

Quote:
Originally Posted by stovak View Post
In your game folder you should have a folder called "EXE". In there is a subfolder, "Client_RU" containing 4 alternative il2fb.exe files. They allow different amounts of RAM use for Java. My limited understanding is that you should use the largest one that works for you. The other folders contain other versions for use with mods.

Might as well try it I guess, but I don't think this will fix whatever is causing your map problem. I only have a GTX960 and the 'Battle for...' maps load fine. I tried it with the 96MB and 1024 exes and it works with either.
I found that those maps work quite well on the 1024 MB .exe file. However, I ran into another couple of problems:

First, when I try to play a mission set on a large map (e.g. Battle for Moscow or the Solomons maps), sometimes the mission wouldn't load even when I may only have one unit on the map. In those cases, it would display an error message saying "Mission loading failed: Mesh 3do/humans/Paratroopers/[insert country here]/mono.sim not created"; the country it would mention would usually either be Russia or Germany. I have no idea why it would do that at all; it also seems to not matter which of the .exe files I try, as the tendency to spit out these error messages would remain about the same.

Second, even though I've mentioned that my computer should be able to put out playable framerates for a number of games (including this one), when I tried flying over Moscow on the Battle for Moscow (just a single, player-controlled plane, no other units), the framerates dropped to single-digit speeds. When I face away from there, the framerates improve, but only by a few FPS. It seems that there's an issue with how all those various models on the ground have to be rendered, even though my hardware should at least theoretically be up to the task. I'm not sure how well optimized the rendering system is, but it may need at least some tweaking. Perhaps there's also other factors that I don't yet understand or know about, as well.

In any case, I hope that there's a way to fix these immediately, or failing that, the dev team could do some more work in fixing these bugs and other issues in the next hotfix/patch or thereabouts!
Reply With Quote