View Single Post
  #1  
Old 08-06-2011, 03:52 PM
festa_freak festa_freak is offline
Junior Member
 
Join Date: Aug 2011
Posts: 2
Default Can't get on boat

Hello,

I've tried to search for a similar issue but cannot find. I was in the underground sea and got the boat, and went to the teleporting bridge thing that goes to demonis.

I was able to click onto the platform from the boat. I went into demonis and saw that my level 15 paladin wasn't going to cut it and went back. I saw that the platform moved and continued on my journey. Now I need the boat for a quest (non-main quest) and I just can't get back to my boat. I've tried taking the platform across and wildly clicking to try to get back in boat but no luck.

Has anyone else come across this and is there any way to correct it? Thanks.

This wouldn't be a huge problem but the XP reward is 1800 which is 6 times what most quests offer and it is such a simple quest too. Just pick up plants.

Last edited by festa_freak; 08-06-2011 at 04:08 PM.
Reply With Quote