View Single Post
Old 12-07-2012, 11:31 PM
G-man G-man is offline
Junior Member
Join Date: Dec 2012
Posts: 1

Ok I bought the game yesterday off steam and I think this may be a glitch. I've been doing the quests and there was one where I am to deliver a package for the USS corporation. However their escort was taken over by pirates and I have to fight them, (with the help of mercs hired beforehand).

Now on my way to deliver the goods to the USS, they want to know what happened, so I take them to the battleground and they get their escort's black boxes. They ask me to find the pirate base which is nearby however once found a swarm of pirates emerge and proceed to kill my team (its 5 to one). Ternie says something about bringing in the cavalry however there are no cavalry to be had.

If you move your entire team to search for the pirates there is no rescue from USS forces, if you leave a fighter behind to see what they do, they simple disappear when you discover the pirate base, if you try going back through the gate to where the USS guys came from they claim you tried to cheat them and blow you up automatically...

I sincerely hope that the developers don't expect me to take on 5 times the amount of pirates so early in the game (this is like my 5th mission), if not then what am I doing wrong? (I have no idea since I've tried everything I could, even tried to sweep the area before I lose the merc guys).

Overall I'm a tad annoyed about this.
Reply With Quote