1C Home   |   Register   |   Today Posts   |   Members   |   UserCP   |   Calendar   |   Search   |   FAQ

Go Back   Official 1C Company forum > 1C Publishing > IL-2 Sturmovik > Daidalos Team discussions

Reply
 
Thread Tools Display Modes
  #1  
Old 04-07-2020, 05:56 PM
dimlee's Avatar
dimlee dimlee is offline
Approved Member
 
Join Date: Oct 2010
Location: Europe
Posts: 299
Default 4.14.1 timeout 0 black magic

When 4.14 was just released I was not able to join any 4.14 multiplay server due to "timeout 0" error.
Some people who ran their servers were kind enough to advise that whenever I tried to join, the server reported the followihg: "Cheater was detected! Reason=4: 'Radar' ".
I never ever had any "cheat" programs on my computers but I decided to check and to change everything I could. New clean instal from Platinum CD, different ways to upgrade up to 4.14, Steam version tried, COG version tried...
No success. Connections to 4.13 servers were OK, to 4.14 servers - "timeout 0".

Recently I got a chance to start from the zero, so to say. New desktop was acquired and I decided to try my luck again.
New hardware, new OS (Win 10 instead of Win 8.1), no old software transferred to new computer except the IL2 itself.
Same story. Perfect connection to 4.13.4 servers and "timeout 0" message with 4.14.1 servers.
I scratched my head and decided to kick out the last element which was common for old and new computer - my Internet provider. Smartphone switched into hotspot mode and desktop wifi connected to the hotspot... No success. 4.13.4 servers OK, 4.14.1 servers - "Timeout 0".

And since I tried everything I could think of, the only explanation is...
...
Gremlins. They are real.
__________________
Q: Mr. Rall, what was the best tactic against the P-47?
A: Against the P-47? Shoot him down!
(Gunther Rall's lecture. June 2003, Finland)
Reply With Quote
  #2  
Old 04-08-2020, 04:09 PM
nevr44 nevr44 is offline
Approved Member
 
Join Date: Nov 2012
Posts: 8
Default

Quote:
Originally Posted by dimlee View Post
Recently I got a chance to start from the zero, so to say. New desktop was acquired and I decided to try my luck again.
New hardware, new OS (Win 10 instead of Win 8.1), no old software transferred to new computer except the IL2 itself.
Same story. Perfect connection to 4.13.4 servers and "timeout 0" message with 4.14.1 servers.
I scratched my head and decided to kick out the last element which was common for old and new computer - my Internet provider. Smartphone switched into hotspot mode and desktop wifi connected to the hotspot... No success. 4.13.4 servers OK, 4.14.1 servers - "Timeout 0".

And since I tried everything I could think of, the only explanation is...
...
[/IMG]

On the website AviaSkins.Forums have dealt with a similar situation.
You need to clean the Windows registry
Reply With Quote
  #3  
Old 04-08-2020, 04:49 PM
Sita Sita is offline
Approved Member
 
Join Date: Oct 2007
Posts: 909
Default

Quote:
Originally Posted by nevr44 View Post
On the website AviaSkins.Forums have dealt with a similar situation.
You need to clean the Windows registry

really? where to read?

in fact all my simple solution which was helpfull in some similar sutuation in that case don't work unfortunatly .... and i have nothing to advice ((
__________________
work hard, fly fast

Reply With Quote
  #4  
Old 04-08-2020, 09:00 PM
dimlee's Avatar
dimlee dimlee is offline
Approved Member
 
Join Date: Oct 2010
Location: Europe
Posts: 299
Default

Quote:
Originally Posted by nevr44 View Post
On the website AviaSkins.Forums have dealt with a similar situation.
You need to clean the Windows registry

I'll be happy to try another solution but could you elaborate some more please?
If that means "automatic" registry cleaning, I do that with Eusing Registry Cleaner from time to time.
__________________
Q: Mr. Rall, what was the best tactic against the P-47?
A: Against the P-47? Shoot him down!
(Gunther Rall's lecture. June 2003, Finland)
Reply With Quote
  #5  
Old 04-09-2020, 05:54 PM
nevr44 nevr44 is offline
Approved Member
 
Join Date: Nov 2012
Posts: 8
Default

Quote:
Originally Posted by dimlee View Post

I'll be happy to try another solution but could you elaborate some more please?
If that means "automatic" registry cleaning, I do that with Eusing Registry Cleaner from time to time.

I can't remember where it was discussed, but I remember that deleting the registry keys of a remote mod program helped. Manual search.
I'm not sure about AviaSkins.Forums anymore. Important the mod had access to the network.
Reply With Quote
  #6  
Old 04-10-2020, 11:00 AM
dimlee's Avatar
dimlee dimlee is offline
Approved Member
 
Join Date: Oct 2010
Location: Europe
Posts: 299
Default

Quote:
Originally Posted by nevr44 View Post
I can't remember where it was discussed, but I remember that deleting the registry keys of a remote mod program helped. Manual search.
I'm not sure about AviaSkins.Forums anymore. Important the mod had access to the network.
Thank you, it sounds reasonable. We just missing this "mod program" name.

I remember discussions about Winpcap. It did not allow some users (including myself) to install 4.14 until all traces were removed, from the registry as well.
Still, after everything winpcap related was removed, I could not join 4.14 servers on my previous PC.

In my new PC the hardware is fresh, disks wiped, OS just installed. But I did not check it for that treacherous Winpcap, my fault. Could it be a part of the Win 10 installation, I wonder... I'll check when I'm back home.

Gremlin hunting goes on.
__________________
Q: Mr. Rall, what was the best tactic against the P-47?
A: Against the P-47? Shoot him down!
(Gunther Rall's lecture. June 2003, Finland)
Reply With Quote
  #7  
Old 04-12-2020, 07:00 PM
dimlee's Avatar
dimlee dimlee is offline
Approved Member
 
Join Date: Oct 2010
Location: Europe
Posts: 299
Default

And the name of the gremlin is...
Winpcap.
Thanks to nevr44 for reminding about that treacherous little weasel which finds its way through other programs.
The problem is that it generates several files with the names other than "winpcap". Luckily, Win 10 search can find them.

Files deleted, registry checked.
And I am able to join 4.14 servers. The problem is resolved.

__________________
Q: Mr. Rall, what was the best tactic against the P-47?
A: Against the P-47? Shoot him down!
(Gunther Rall's lecture. June 2003, Finland)
Reply With Quote
  #8  
Old 04-13-2020, 12:22 PM
Sita Sita is offline
Approved Member
 
Join Date: Oct 2007
Posts: 909
Default

I already despaired to help you with that if to be honest ..
Glad that you have find the solution
__________________
work hard, fly fast

Reply With Quote
  #9  
Old 04-14-2020, 04:11 PM
dimlee's Avatar
dimlee dimlee is offline
Approved Member
 
Join Date: Oct 2010
Location: Europe
Posts: 299
Default

Quote:
Originally Posted by Sita View Post
I already despaired to help you with that if to be honest ..
Glad that you have find the solution
Sita, you did your best and I'm grateful for the advises given.
__________________
Q: Mr. Rall, what was the best tactic against the P-47?
A: Against the P-47? Shoot him down!
(Gunther Rall's lecture. June 2003, Finland)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:24 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright © 2007 1C Company. All rights reserved.