1C Home   |   Register   |   Today Posts   |   Members   |   UserCP   |   Calendar   |   Search   |   FAQ

Go Back   Official 1C Company forum > 1C Publishing > Cryostasis > Technical issues

Technical issues Everything about technical problems and issues

Reply
 
Thread Tools Display Modes
  #11  
Old 09-15-2010, 08:20 AM
Lazarus187 Lazarus187 is offline
Junior Member
 
Join Date: Sep 2010
Posts: 9
Default

Still can't find it. Would it be possible for you to post several saves from Chapter 17, say at the beginning, and perhaps several minutes in? Thanks!
Reply With Quote
  #12  
Old 09-15-2010, 08:57 AM
Sneaksie Sneaksie is offline
Administrator
 
Join Date: Mar 2008
Posts: 824
Default

Here is a quicksave from the beginning of chapter 17. Unpack thiz archive into Cryostasis\Data\Save folder overwriting existing files.
Attached Files
File Type: zip Save.zip (1.08 MB, 5 views)
Reply With Quote
  #13  
Old 09-17-2010, 01:06 AM
Lazarus187 Lazarus187 is offline
Junior Member
 
Join Date: Sep 2010
Posts: 9
Default

Alright, found your saved game this time. Attempted to load it, and.... same issue I was having, with the same exact error message regarding "too many script variables".

I really don't understand what the issue is with Chapter 17, and ONLY Chapter 17. I swear I haven't had any problems like this with any other chapter, and other than an intermittent and annoyingly low frame rate due to the game's inefficient use of resources, it generally runs fine.
Reply With Quote
  #14  
Old 09-17-2010, 07:02 AM
Sneaksie Sneaksie is offline
Administrator
 
Join Date: Mar 2008
Posts: 824
Default

Puzzling... I suggest you do the following:

1) Install AMD Dual Core Optimizer from AMD site.
2) Download and install latest video drivers for XP from nVidia site. Make sure PhysX is updated as well in the process.
3) Go to nVidia Control Panel and set PhysX to be calculated on CPU, not your video card (it helped me in one place in Cryostasis where i got a PhysX error).
4) Run the game and temporarily set all options to low or off, then try to load the save.

If problem persists, uninstalling the game, deleting its folder and reinstalling it and 1.1 patch may also help.
Reply With Quote
  #15  
Old 09-21-2010, 12:26 AM
Lazarus187 Lazarus187 is offline
Junior Member
 
Join Date: Sep 2010
Posts: 9
Default

Quote:
If problem persists, uninstalling the game, deleting its folder and reinstalling it and 1.1 patch may also help.
Figures....following your last suggestion seems to have finally resolved the problem, at least for the time being. Just for the record, I've had AMD's dual-core optimizing utility installed and running for several years now, and I do have the latest display drivers from Nvidia as well.

Now that I've got the game running at least, I wanted to see if you have some suggestions for improving the rather abysmal framerates of this resource-hogging game. Here are the settings I'm running the game at now:

Code:
Resolution:  1280 x 1024
VSync:  Off
Shader Model:  2.0  ( Whatever that means )
Hardware Physics:  Off
Advanced PhysicX Effects:  Off
Texture Resolution:  Medium
Normal Maps:  Medium
Specular Maps:  Medium ( Does this refer to weapon speculars? )
Shadows:  Medium
Motion Blur:  Off
Water Reflect:  On
Water Caustic:  On  ( What is this? )
Anisotropic Filtering:  Off
Antialiasing:  Off
I'd hate to lower the resolution, as most games begin looking rather "grainy" below 1280 x 1024. I'm not really certain which of the aforementioned settings is "draining" the most resources on my system, nor do I know if this game is CPU or GPU dependent, or both. On that note, here are my system specs:

Code:
OS:  Windows XP Home Edition (5.1, Build 2600) Service Pack 3
CPU:  AMD Athlon 64 FX-60 Dual Core Processor ~2.6GHz 
GPU:  BFG NVIDIA GeForce GTX 275 ~896.0 MB
Sound:  Creative Labs  SB Audigy 2 ZS Audio [7000] 
RAM:  2048 MB
In any event, you've been a GREAT help, and I do sincerely appreciate your advice and assistance. Have a great one.

Last edited by Lazarus187; 09-21-2010 at 01:58 AM.
Reply With Quote
  #16  
Old 09-21-2010, 07:15 AM
Sneaksie Sneaksie is offline
Administrator
 
Join Date: Mar 2008
Posts: 824
Default

The biggest performance hit comes from Hardware Physics: Off, since all PhysX is being calculated on your CPU which already has much to do in this game and is kinda old already. Set it to On, also set Shaders to 3.0 if available (in theory it may actually boost performance). However, as i said earlier, if you have an error in Cryostasis, setting HW physics to off may help you to proceed.
You have a good video card, but slow CPU. Consider upgrading to modern CPU and motherboard, you should be able to keep other components (except RAM maybe). And install Win7 to use all features of Dx10&11 (however, you'll run into some problems with Creative drivers to keep EAX in games).
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:42 AM.

Based on a design by: Miner Skinz.com

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 2007 1C Company. All rights reserved.