1C Home   |   Register   |   Today Posts   |   Members   |   UserCP   |   Calendar   |   Search   |   FAQ

Go Back   Official 1C Company forum > 1C Publishing > IL-2 Sturmovik: Cliffs of Dover > Technical threads > Performance threads

Performance threads All discussions about CoD performnce

Reply
 
Thread Tools Display Modes
  #1  
Old 01-24-2012, 02:37 PM
Flanker35M Flanker35M is offline
Senior Member
 
Join Date: Dec 2009
Location: Finland
Posts: 1,804
Thumbs up AMD 7970HD 3Gb and CoD

S!

So today The Card arrived. Just got it installed with latest drivers and had time to quickly run a test with CoD. For AMD users oh the joy, the 3 lines of death are GONE!! YESSS!! Spit vs 110 track..maximum 68fps minimum 2fps(when it loads into cockpit), average 60FPS! I have VSync on.

Will do some more testing and report in this thread, but from what I tested the card is DAMN fast! Could not be happier!!!!!!
Reply With Quote
  #2  
Old 01-24-2012, 03:08 PM
Ataros Ataros is offline
Senior Member
 
Join Date: Jun 2010
Location: USSR
Posts: 2,438
Default

Congratulations! And great news on 3 lines of death

Could you run the test with SSAO on and off, and with vsynk off and on also just to compare to gtx580 performance tests from here http://translate.google.com/translat...hp%3Ft%3D68723

What is your AA setting and resolution? With vsync ON triple buffering must be forced ON I think to avoid short drops to 30 fps in complex scenes.

gtx 580 results vary from 51 average to 65 with vsynk and SSAO off. Clouds ON in realism settings.

43 avg with SSAO and vsynk ON AA 4x 1920x1080

You can pause the track after loading cockpit and only then start the counter to avoid 2 min fps. You may also first run it once without a counter to load all textures into memory and record results only in the 2nd run. This is how they tested 580 and other cards there.

Do you experience the stripes bug on the border of land and water?

PS. E.g. sample results for 580:
Quote:
I5-2500К-3.3GHz
min=13/14/15
avg=45/46
max=113/114/119

I5-2500К@4.0GHz
min=14/15/17
avg=50/51
max=134/138/140

I5-2500К@4.5GHz
min=14/15
avg=55/56
max=152/156/160

SSAO=off, AA=off, VSYNC=off.

ASRock P67 Extreme6 / Gainward GTX 580 / DDR3 1600 G.Skill 3X4 Gb / Crucial M4 CT128 SSD + CT064M4SSD2 /Asus Xonar Essence STX/ Monitor DELL U2410 1920x1200 / Windows 7 Home Premium - 64 bit / Warthog / TrackIR 5
What are your CPU clocks?

Last edited by Ataros; 01-24-2012 at 03:31 PM.
Reply With Quote
  #3  
Old 01-24-2012, 03:19 PM
Sven Sven is offline
Senior Member
 
Join Date: Mar 2010
Location: The Netherlands, Zeeland
Posts: 779
Default

Excellent news! It's just so damn expensive
Reply With Quote
  #4  
Old 01-24-2012, 03:29 PM
Flanker35M Flanker35M is offline
Senior Member
 
Join Date: Dec 2009
Location: Finland
Posts: 1,804
Default

S!

I run the card on the stock settings 925/1372MHz, 1920x1080 32-bit resolution. SSAO is Off as well as AA. Will post my CCC and game settings, need to plug in the joystick etc. again..had CoD kind of shelved before the patch
Reply With Quote
  #5  
Old 01-24-2012, 03:42 PM
Ataros Ataros is offline
Senior Member
 
Join Date: Jun 2010
Location: USSR
Posts: 2,438
Default

Quote:
Originally Posted by Flanker35M View Post
S!

I run the card on the stock settings 925/1372MHz, 1920x1080 32-bit resolution. SSAO is Off as well as AA. Will post my CCC and game settings, need to plug in the joystick etc. again..had CoD kind of shelved before the patch
Thank you very much! Could you please run "The black death" track. The results for gtx580 are for this track. I did not notice you were running a different one, sorry.
Reply With Quote
  #6  
Old 01-24-2012, 04:23 PM
Flanker35M Flanker35M is offline
Senior Member
 
Join Date: Dec 2009
Location: Finland
Posts: 1,804
Default

S!

Ok, made some quick runs with Black Death at 1920x1080 resolution and I think you find out something interesting in results. Mind you I did not clear cache before or between the tests, it MIGHT have an effect but anyway..here settings and numbers!

CCC Settings, Performance driver 11.12 from AMD

Antialiasing Mode : Use application settings, Morphological filtering OFF, Filter Standard.
Anisotropic Filtering : Use application settings
Tessellation: AMD Optimized (I think has no effect in CoD whatsoever)
Catalyst AI : Performance, Surface optimization Off
Vertical refresh : On, unless application specifies
Triple Buffer : Off (OpenGL setting only)

First runs I ran at what I had from my 6970HD. Cache was NOT cleared nor game restarted between runs in any phaze.

In-game settings...

Full Screen : On
Antialiasing : Off(in all tests)
Epilepsy : Off (in ALL tests)
SSAO : Off
Vsync : On

Model detail : High
Building detail : High
Land Detail : High
Forest : Low
Visual effects : Medium
Texture Quality : High

Damage decals : High
Buidlings amount : Unlimited
Land shading : High

Grass : Off
Shadows : On
Roads : On

Black Death ran once to load textures. Then the benchmarking run with FPS counter on. Counter was reset on each run to get consistent results.

Minimum: 10fps
Maximum: 68fps
Average: 45fps

Next run with VSync OFF, otherwise all remained same.

Minimum: 10fps
Maximum: 112fps
Average 48fps

Next run with SSAO ON, VSync Off. Otherwise similar settings. This was interesting!

Minimum: 10fps
Maximum: 111fps
Average: 47fps

Next run SSAO ON, VSync ON. Otherwise similar settings. Again interesting!

Minimum: 10fps
Maximum: 67fps
Average: 44fps

Then I changed graphics settings to VERY HIGH, VSync ON. Interesting average, should run another run?

Minimum: 5fps
Maximum: 67fps
Average: 34fps

Last run VERY HIGH, VSync OFF. Interesting results again..

Minimum: 5fps
Maximum: 112fps
Average: 45fps

So here a quick and dirty testing. Will do some cahce clearing and other tweaks. My system runs ALL at STOCK speeds, no overclocking. Signature for more info

Last edited by Flanker35M; 01-24-2012 at 04:28 PM.
Reply With Quote
  #7  
Old 01-24-2012, 04:57 PM
Ataros Ataros is offline
Senior Member
 
Join Date: Jun 2010
Location: USSR
Posts: 2,438
Default

Thanks for sharing so detailed report!

Quote:
Originally Posted by Flanker35M View Post

First runs I ran at what I had from my 6970HD. Cache was NOT cleared nor game restarted between runs in any phaze.
Your registry may also have data remaining from 6970. It may help to make a clean reinstall of the drivers with DriverSweeper or DriverCleaner in safe mode.

The stock speed of your CPU is only 3.3GHz that can limit such a fast card like this one similar to gtx580 sample in my 1st post above. Do you have any utility to log your CPU load during the test? "Black Death" is very processor dependant I guess.

Highest texture setting is "Original". It is higher than "High".

Last edited by Ataros; 01-24-2012 at 05:04 PM.
Reply With Quote
  #8  
Old 01-24-2012, 05:00 PM
Flanker35M Flanker35M is offline
Senior Member
 
Join Date: Dec 2009
Location: Finland
Posts: 1,804
Default

S!

Did clear the game cache to see if any difference. Settings in game are VERY HIGH. In CCC same as previous post. Results with and without VSync below.

Vsync ON

Minimum: 5fps
Maximum: 67fps
Average: 43fps


VSync OFF

Minimum: 5fps
Maximum: 112fps
Average: 45fps


So as an conclusion so far can say SSAO has almost no effect on any area of performance as it had before. Propably for best game play I would use VERY HIGH as base but change the following:

Building Detail: High, from Very High
Forest: Low or Medium, from maximum
Texture Quality: High, from Original
Visual Effects: Medium, from High

Will run a test with those changes and report back shortly.
Reply With Quote
  #9  
Old 01-24-2012, 05:19 PM
Ataros Ataros is offline
Senior Member
 
Join Date: Jun 2010
Location: USSR
Posts: 2,438
Default

Quote:
Originally Posted by Flanker35M View Post
So as an conclusion so far can say SSAO has almost no effect on any area of performance as it had before.
This would be very strange unless processor is the bottle-neck.

Could you log your processor and or GPU load percentage?
Reply With Quote
  #10  
Old 01-24-2012, 05:25 PM
Flanker35M Flanker35M is offline
Senior Member
 
Join Date: Dec 2009
Location: Finland
Posts: 1,804
Default

S!

Ran Vsync on/off tests with settings above. Results were OK, not much difference but again the track does not represent actual gameplay IMO. But the results

VSync ON

Minimum: 6fps
Maximum: 68fps
Average: 44fps

VSync OFF

Minimum: 11fps
Maximum: 112fps
Average: 46fps

Do you use a logging program of some sort Ataros, will gladly provide CPU/GPU usage stats for you
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:34 PM.

Based on a design by: Miner Skinz.com

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 2007 1C Company. All rights reserved.