1C Home   |   Register   |   Today Posts   |   Members   |   UserCP   |   Calendar   |   Search   |   FAQ

Go Back   Official 1C Company forum > 1C Publishing > IL-2 Sturmovik: Cliffs of Dover > FMB, Mission & Campaign builder Discussions

Reply
 
Thread Tools Display Modes
  #1  
Old 12-01-2012, 04:20 PM
moggel moggel is offline
Approved Member
 
Join Date: Mar 2011
Posts: 70
Default Actor is null and I/O errors

Hey scripters,

I've seen that the OnPlaceEnter(AMission mission, Player player, AiActor actor, int placeIndex) handler sometimes gets passed a null value for 'actor'. Is this a known bug in the sim? When it happens I usually try get the actor from player.Place() and it seems that works but not always. Has anyone else seen this?

Also, sometimes when I call the GamePlay.gpLogServer(...) method I get an I/O error.

I've only seen these problems on dedicated server but I don't know if it could happen in SP play or on a local server.

Any hints/suggestions would be appreciated.

/mog
__________________
Core i7 3930K @ 4.8GHz; 16Gb DDR3 (Vengeance); nVidia GTX580; OS disk: 150Gb 10000rpm; SIM disk: 300Gb 10000rpm; Windows 7 x64 Ultimate
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:37 PM.

Based on a design by: Miner Skinz.com

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 2007 1C Company. All rights reserved.