1C Home   |   Register   |   Today Posts   |   Members   |   UserCP   |   Calendar   |   Search   |   FAQ

Go Back   Official 1C Company forum > Other > Technical Issues

Technical Issues Having problems with launching or running a 1C game on your hardware? Try asking other gamers, they may know the answer.
For 1C technical support, send us an email.

Reply
 
Thread Tools Display Modes
  #1  
Old 11-15-2012, 02:11 AM
BenSt88 BenSt88 is offline
Junior Member
 
Join Date: Nov 2012
Location: USA
Posts: 23
Default Mac problem w/ King's Bounty: Warriors of the North

This is a cross-post taken from what I just listed in the 1st Bugs thread (sticky) in that game's forums. But it's mainly about overall technical issues rather than a specific bug, so I'll try here as well. I am desperate to be able to play and enjoy this game!

Well that didn't work (copy & paste)! I'll just get to the point then

Bought the game shortly after the November 9th patch on Steam, for the Mac. My main issue, and the reason I've stopped playing it, as that no matter what I do in the Options sub-screen, all my textures are "low", which makes for blurred and ugly images. After playing KB: AP (3x) and KB: TL (2x), I know what the game should look like on my Mac.

I have scoured many different forums looking for an answer, and come up w/ nothing. The only thing that worked for 1 user--and he might have been on a PC, I don't know--was switching everything to low textures, and then back to high. But that didn't do anything either.

My system: MacPro 3.1 [early 2008] Quad-Core Intel Xeon @ 2.80 GHz; 2.0 GB RAM; Mac OS X Lion 10.7.5; ATI Radeon HD 2600 XT 256 MB.

Also, every time I log out (exit from the main screen), I get a crash log & report sent off to Apple. So I know something is consistently wrong. If it would be helpful to start the game up and get a copy of that crash log and send it to you, please let me know.

I hope you can help me! Thanks for reading.
Reply With Quote
  #2  
Old 12-14-2012, 06:35 AM
Cantello Cantello is offline
Approved Member
 
Join Date: May 2010
Posts: 7
Default

Same here and additionally, every time a description of a board element (e.g. statue on the battle field) is displayed, it remains there for as long as the screen is switched, which can be extremely annoying in battle as the kill probabilities are no longer shown.

The Edda song you choose at the beginning of a battle is also very slow, sometimes taking several seconds just to go to the correct song.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:05 PM.

Based on a design by: Miner Skinz.com

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright © 2007 1C Company. All rights reserved.