1C Home   |   Register   |   Today Posts   |   Members   |   UserCP   |   Calendar   |   Search   |   FAQ

Go Back   Official 1C Company forum > 1C Publishing > IL-2 Sturmovik: Cliffs of Dover > Technical threads > Performance threads

Performance threads All discussions about CoD performnce

Reply
 
Thread Tools Display Modes
  #1  
Old 08-07-2012, 12:36 PM
FS~Phat FS~Phat is offline
Moderator
 
Join Date: Dec 2010
Posts: 602
Default NVIDIA 6 series stuttering

This is a little old now but still current and thought some of you might want know if you hadn't seen it and are on old drivers with a 6 series Nvidia card.
So please dont blame everything on the developers and the game!

There are still reportedly issues even with current drivers on some games so it wouldnt surprise me if some of the stutter issues with COD are related because I get zero stutters on 5 series hardware and some users are still reporting issues on 6 series hardware.

The thread on the Nvidia forums is almost 95 pages. At first, this issue was passed off as some minor bug, and presently , has several Nvidia engineers whose sole purpose is this bug and working to fix it, so far 3 different causes of frame hitching have been fixed. This is still not completely resolved.

Game and tech forums globally are full of threads about this issue across many games including BF3 that people love to compare to COD! :O
Games confirmed effected that ive found in a quick search.. There are sure to be others...
BF3
Rage
Titan Quest
Dirt 3
Sniper Elite V2
Diablo 3

Here's an extract from Toms Hardware. http://www.tomshardware.com/news/GeF...Fix,15670.html

"Tom's Hardware has received several requests to look into a v-sync issue that a number of owners are seeing with Nvidia's new GeForce GTX 600-series graphics cards. A number of readers have pointed us in the direction of a very long forum thread where multiple customers express concern over stuttering problems with their Kepler-based graphics cards."

NVIDIA's Official Response...
We have received reports of an intermittent v-sync stuttering issue from some of our customers. We’ve root caused the issue to a driver bug and identified a fix for it. The fix requires extensive testing though, and will not be available until our next major driver release targeted for June (post-R300). For users experiencing this issue, the interim workaround is to disable v-sync via the Nvidia Control Panel or in-game graphics settings menu.

Thought it might help some of you still experiencing stutters on newer cards to make sure you disable vsync which is the opposite of what you would logically think! Vsync normally smooths games out.... The frame limiters that people have been using also seems to be another work around for this.

And lastly an interesting post at Guru3d about the issue across multiple platforms and hardware combinations.....
Quote:
"Just like to add that I had this issue with 3 different cpu/mobo builds. X58 & i7 920, x79 & 3820, and z77 & i52550k. I got rid of it prior to moving over to my now current ivybridge. The problem was also with 2 different 680's, a Gainward Phantom and iirc a standard Gainward. The 2 680's having different clock speeds and power phasing.

I did however manage to reduce the issue signifcantly to the point of making it appear non existant during gaming. On a game by game basis, I often resolved by combination of max frames to 60, pre rendered to 1, power management to always max etc etc. Deep diving driver config could resolve those games of which it presented itself for me usually.

Going back to my current 580, resolved the need for any driver tweaks to work around the stutter I had with the 680's. I just found the driver/680 to be a load of hassle on every other game to get working as I wanted.

iirc correctly the latest driver at the time though was the 301.42, of which I personally found the 300.83 to greatly improve the situation. So I cant comment on the situation post those drivers today.

"If this issue is so "minority" associated, as is being alleged on this thread. Then I for one think its strange that I had the issue across so many different set ups and using 2 different 680's. Also if the issue didnt exist for a large number of users, why did the 95 page thread at Nvidia have over 1 million hits before forums went down. And lastly if the issue does not exist, why did Nvidia confirm that it did/does?" end quote

Naughty Nvidia!
__________________
"I need a Figgy Duff"... yep that just about sums it up!
i7 3930K @ 5Ghz AC Kryos Silver WB - Asus Rampage IV Extreme - 4way SLI 3GB GTX 580 Aquagrafx WB - 16GB DDR3-2000 - 4 x GTX 360 rads w/ 24 x CM fans & shrouds - 2 x Enermax 1500W PSU - MM Extended Ascension Horizon XL-ATX Case - 2 x Koolance 452x2 Res and 4 x D5 pumps - 3 x 24" Acer H243H LCD Nv Surround

Last edited by FS~Phat; 08-07-2012 at 12:43 PM.
Reply With Quote
  #2  
Old 08-07-2012, 12:49 PM
Jaws2002 Jaws2002 is offline
Approved Member
 
Join Date: Jan 2008
Posts: 851
Default

This is not only a 600 series problem. It was introduced by one of the drivers. I had this too on the 590. I think the problems is still present in the latest driver, but I already disabled the vsinc.
__________________
----------------------------------------
Asus Sabertooth Z77
i7 3770k@4.3GHz+ Noctua NH D14 cooler
EVGA GTX 780 Superclocked+ACX cooler.
8GB G.Skill ripjaws DDR3-1600
Crucial M4 128GB SSD+Crucial M4 256GB SSD
Seagate 750GB HDD
CH Fighterstick+CH Pro pedals+Saitek X45
Win7 64bit
Reply With Quote
  #3  
Old 08-07-2012, 12:52 PM
FS~Phat FS~Phat is offline
Moderator
 
Join Date: Dec 2010
Posts: 602
Default

Quote:
Originally Posted by Jaws2002 View Post
This is not only a 600 series problem. It was introduced by one of the drivers. I had this too on the 590. I think the problems is still present in the latest driver, but I already disabled the vsinc.
Current drivers reportedly still have the problem and I dont have stuttering in my games so I think its more of a 6 series issue. Certainly most posts in the forums about the place have referenced 6 series from what I saw. Could be just lies damned lies and "internet" ...

Also heres an extract from the Nvidia release notes for R304 but it hasnt completely fixed the issue.

I think you will find your stutter issues are a result of your dual GPU card.

Key Fixes from R304
Fixes an intermittent vsync stuttering issue with GeForce GTX 600-series GPUs.
Fixes an issue where some manufacturer’s factory overclocked cards default to and run at lower clocks.
Fixes a performance issue in Total War: Shogun 2 with the latest game patch.
__________________
"I need a Figgy Duff"... yep that just about sums it up!
i7 3930K @ 5Ghz AC Kryos Silver WB - Asus Rampage IV Extreme - 4way SLI 3GB GTX 580 Aquagrafx WB - 16GB DDR3-2000 - 4 x GTX 360 rads w/ 24 x CM fans & shrouds - 2 x Enermax 1500W PSU - MM Extended Ascension Horizon XL-ATX Case - 2 x Koolance 452x2 Res and 4 x D5 pumps - 3 x 24" Acer H243H LCD Nv Surround

Last edited by FS~Phat; 08-07-2012 at 01:03 PM.
Reply With Quote
  #4  
Old 08-07-2012, 01:17 PM
GraveyardJimmy GraveyardJimmy is offline
Senior Member
 
Join Date: Apr 2011
Posts: 258
Default

I think it is also worth mentioning that there is another bug with Nvidia cards that I suffered from that can cause real problems with gaming and is difficult to pin down. I wasn't sure about sharing the last half of the fix as it can cause irreparable damage to your GPU and is not recommended unless you cannot fix it. It worked for me but I wouldn't easily tell other people to do it- use at your own risk.

Symptoms: You sometimes get good fps when running applications but then other times get poor fps until reboot. This happens seemingly randomly.

I noticed this when playing league of legends. I would get major FPS issues, down from 60fps to a stuttery 28, this continued in other games- including RO2 and CLoD.

It can be a problem in the GTX460 but I have heard of it in other cards, different fixes seem to be required based on the card.

It is caused by the card not triggering into the full 3d power mode and staying in 2d/powerful 2d mode which gives half the clock speed, testable by (for example) MSI afterburner in game.

Fixes:
1- Update drivers (most usually fixes it). This fixes the bug with the power states for some people. Completely uninstalling the old ones first can make a difference.

If it persists:
2- Set power management mode to prefer maximum performance in NVIDIA control panel.

The final fix is dangerous and I would not recommend doing it unless you are very comfortable with making system changes. I have only heard of this fix needing to be done on specific cards (like mine): the Gigabyte GTX460 (1gb, overclocked version). IF you don't have this card, dont try it as I dont want people to get angry with me for sharing this fix.

Gigabyte have released a new BIOS for the GPU (not mb) which fixes problems in power states. This was the only fix that would stop the GPU from clocking down after having switched to 2D rendering back to 3D. I will not link to it, but it is available on their website if you look for your model. Always make a backup of your GPU bios and do not attempt if you have fears about your PSU, power surges, internet corruption etc. Replacing the BIOS can brick your card if anything goes wrong.

As I said, this last option is only for specific cases. My friend only had to update drivers so don't forge ahead and do it anyway. This problem had been affecting me for months and was making gaming pretty bad. Sometimes I flew CLoD at 40fps, other times 15.

Last edited by GraveyardJimmy; 08-07-2012 at 01:21 PM.
Reply With Quote
  #5  
Old 08-07-2012, 01:39 PM
wolf74 wolf74 is offline
Junior Member
 
Join Date: Jun 2011
Posts: 11
Default

I have a Gainward GTX 670 Phantom and no stutters here. Neither in BF3...I must try Diablo III (I've just formatted).
P.S.: Latest beta drivers installed.
Reply With Quote
  #6  
Old 08-07-2012, 01:40 PM
Wolf_Rider Wolf_Rider is offline
Approved Member
 
Join Date: Dec 2007
Location: Sydney, Australia
Posts: 1,677
Default

If you're running an Intel RST (Rapid Storage Technology) check what version you are running... if it is anything higher than the 11.2.0.1006 release, you may have been boned by an unintentional (yet WHQL signed driver - go figure) memory leak associated with it.
It also appears to be a bit of a mess to uninstall.

Another to try is to set (nVidia cpl) setting Threaded Optimisation to OFF
__________________
Intel 980x | eVGA X58 FTW | Intel 180Gb 520 SSD x 2 | eVGA GTX 580 | Corsair Vengeance 1600 x 12Gb | Windows 7 Ultimate (SP1) 64 bit | Corsair 550D | Corsair HX 1000 PSU | Eaton 1500va UPS | Warthog HOTAS w/- Saitek rudders | Samsung PX2370 Monitor | Deathadder 3500 mouse | MS X6 Keyboard | TIR4

Stand alone Collector's Edition
DCS Series



Even duct tape can't fix stupid... but it can muffle the sound.

Last edited by Wolf_Rider; 08-07-2012 at 01:56 PM.
Reply With Quote
  #7  
Old 08-07-2012, 02:12 PM
BH_woodstock BH_woodstock is offline
Senior Member
 
Join Date: Feb 2010
Location: atm in catskill state park
Posts: 227
Default

Quote:
Originally Posted by GraveyardJimmy View Post
I think it is also worth mentioning that there is another bug with Nvidia cards that I suffered from that can cause real problems with gaming and is difficult to pin down. I wasn't sure about sharing the last half of the fix as it can cause irreparable damage to your GPU and is not recommended unless you cannot fix it. It worked for me but I wouldn't easily tell other people to do it- use at your own risk.

Symptoms: You sometimes get good fps when running applications but then other times get poor fps until reboot. This happens seemingly randomly.

I noticed this when playing league of legends. I would get major FPS issues, down from 60fps to a stuttery 28, this continued in other games- including RO2 and CLoD.

It can be a problem in the GTX460 but I have heard of it in other cards, different fixes seem to be required based on the card.

It is caused by the card not triggering into the full 3d power mode and staying in 2d/powerful 2d mode which gives half the clock speed, testable by (for example) MSI afterburner in game.

Fixes:
1- Update drivers (most usually fixes it). This fixes the bug with the power states for some people. Completely uninstalling the old ones first can make a difference.

If it persists:
2- Set power management mode to prefer maximum performance in NVIDIA control panel.

The final fix is dangerous and I would not recommend doing it unless you are very comfortable with making system changes. I have only heard of this fix needing to be done on specific cards (like mine): the Gigabyte GTX460 (1gb, overclocked version). IF you don't have this card, dont try it as I dont want people to get angry with me for sharing this fix.

Gigabyte have released a new BIOS for the GPU (not mb) which fixes problems in power states. This was the only fix that would stop the GPU from clocking down after having switched to 2D rendering back to 3D. I will not link to it, but it is available on their website if you look for your model. Always make a backup of your GPU bios and do not attempt if you have fears about your PSU, power surges, internet corruption etc. Replacing the BIOS can brick your card if anything goes wrong.

As I said, this last option is only for specific cases. My friend only had to update drivers so don't forge ahead and do it anyway. This problem had been affecting me for months and was making gaming pretty bad. Sometimes I flew CLoD at 40fps, other times 15.

hmm , I have the same problem with my EVGA gtx460 and noticed that after a reboot the problem mostly goes away.I am still using the 103 beta driver.maybe i should get a newer driver?


amd dual core 5400
gtx460se
6gb ram
Win7 ultimate (performance mode)
Reply With Quote
  #8  
Old 08-07-2012, 02:50 PM
Stublerone Stublerone is offline
Senior Member
 
Join Date: Sep 2011
Posts: 250
Default

I know that problem caused by vram on nvidia cards at arma 2, but this should already be fixed by nvidia. There was a key combination or work around, how to unload the vram on the fly without rebooting. But I don't know, if this fault perhaps came back in some ways???

590 = live with stutters as it is your dual card causing it in close work to the vram. Again I have to say my opinion: Bad technique causes bad and unefficient work!

This power setting issue sounds like the problem with ati cards, which are running only at 500mhz video mode, when watching tracks. Perhaps, this problem is now also arising for imprved power settings of the nvidia cards? Did you already delete the ubi teaser file? This forces ati's to run only in video mode.

And again: stutters with a 680 should happen, because they again have insufficient vram! See phat's testings!
Reply With Quote
  #9  
Old 08-07-2012, 08:37 PM
ramstein ramstein is offline
Approved Member
 
Join Date: Oct 2007
Posts: 269
Lightbulb

I have a PNY GTX460 (factory oc) video card, and don't have any problems,,, no stuttering, good fps..
it is on an older MSI P7N motherboard with 4 gb ddr2 ram...

I use the latest video drivers..

This is just an FYI, not to just say, hey I don't have problems with my gtx460 in 2d/3d, just sayin' it's a good video card.. I have had it about 1 year.

Of course with several flight sims, once in a while something gets bugged and I have to restart, or reboot, but that's normal for all computers...

I used to run ATI / Radeon, but Nvidia work much much better for me and my friends for flight sims.. (Opinion).
Reply With Quote
  #10  
Old 08-07-2012, 11:49 PM
NedLynch NedLynch is offline
Senior Member
 
Join Date: Jul 2011
Location: Southeast Florida, USA
Posts: 390
Default

I just bought a evga gtx670 ftw and I ran CoD, Skyrim, Alan Wake, Crysis2 and Shogun2 with it and did not encounter any stutters.
I am however using the latest beta driver and have v-sync enabled in most games together with triple buffering.

As previously posted, the 304.xx beta driver officially is made to fix intermittend stuttering due to v-sync, that made me use that driver, didn't even try the latest whql driver.

For anyone who is thinking about a 670, all I can say is it took me a long time to be able to upgrade my gpu and I am very happy I did. Performance is awesome (compared to my old 470) and the card runs silent and about 10 to 15 celsius lower under load (with increased settings) with the same afterburner fan profile that I used for my old card. It is at average at about 50 to 55 celsius and so far nerver broke 62 celsius.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:58 PM.

Based on a design by: Miner Skinz.com

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 2007 1C Company. All rights reserved.