1C Home   |   Register   |   Today Posts   |   Members   |   UserCP   |   Calendar   |   Search   |   FAQ

Go Back   Official 1C Company forum > 1C Publishing > IL-2 Sturmovik: Cliffs of Dover

IL-2 Sturmovik: Cliffs of Dover Latest instalment in the acclaimed IL-2 Sturmovik series from award-winning developer 1C: Maddox Games.

Reply
 
Thread Tools Display Modes
  #1  
Old 02-16-2011, 03:31 PM
meplay meplay is offline
Senior Member
 
Join Date: Sep 2010
Posts: 253
Default Need help for ATI confi ini best settings

I just want to know if i need to change anything

Here is my confi ini

[il2]
title=Il2-Sturmovik Forgotten Battles
hotkeys=HotKey game

[window]
width=1680
height=1050
ColourBits=32
DepthBits=24
StencilBits=8
ChangeScreenRes=1
FullScreen=1
DrawIfNotFocused=0
EnableResize=0
EnableClose=1
SaveAspect=0
Use3Renders=0

[GLPROVIDER]
GL=Opengl32.dll

[GLPROVIDERS]
Open GL=Opengl32.dll
DirectX=dx8wrap.dll

[NET]
speed=8000
routeChannels=0
serverChannels=31
localPort=21000
remotePort=21000
SkinDownload=1
serverName=No Name
serverDescription=
remoteHost=204.80.88.43
localHost=78.144.146.22
socksHost=
checkServerTimeSpeed=1
checkClientTimeSpeed=0
remoteHost_000=204.80.88.43:21000
remoteHost_001=

[MaxLag]
farMaxLagTime=10.0
nearMaxLagTime=2.0
cheaterWarningDelay=5.0
cheaterWarningNum=-1

[chat]
region=(dx=0.9880952,dy=0.11523809,x=0.0,y=0.0)
adr0=ALL
msg0=<targets
adr2=To\u0020Server
adr1=MY_ARMY
msg1=<gunstat
msg2=<lives
msg3=<time

[game]
Arcade=0
HighGore=0
mapPadX=7.142857E-4
mapPadY=0.33333334
viewSet=49
Intro=0
NoSubTitles=0
NoChatter=0
NoHudLog=0
NoLensFlare=0
iconTypes=2
eventlog=eventlog.lst
eventlogkeep=0
3dgunners=1


[HotKey game]
PrintScreen=ScreenShot
P=pause
Pause=pause

[HotKey gui]
Escape=activate

[HookViewFly Config]
timeFirstStep=2.0
deltaZ=10.0

[HookView]
MouseLeft=Len

[HookView Config]
AzimutSpeed=0.1
TangageSpeed=0.1
LenSpeed=1.0
MinLen=1.0
DefaultLen=20.0
MaxLen=3000.0
Speed=6

[HotKey builder]
MouseLeft=objectMove
MouseRight=popupmenu
Enter=freeView
Shift MouseLeft=worldZoom
Alt MouseLeft=select+
Alt MouseRight=select-
Alt Ctrl=unselect
PageDown=change+
PageUp=change-
End=change++
Home=change--
Ctrl MouseLeft=insert+
Insert=insert+
NumPad-0=insert+
F=fill
Ctrl MouseRight=delete+
NumPad.=delete+
Delete=delete+
Backspace=cursor
Tab=cursor
F10=land
F11=onLand
NumPad-=normalLand
NumPad+=toLand
NumPad-5=resetAngles
NumPad-8=resetTangage90
NumPad-7=stepAzimut-5
NumPad-4=stepAzimut-15
NumPad-1=stepAzimut-30
NumPad-9=stepAzimut5
NumPad-6=stepAzimut15
NumPad-3=stepAzimut30

[MouseXYZ]
F1=SpeedSlow
F2=SpeedNormal
F3=SpeedFast
MouseRight=XYmove
F4 MouseRight=Zmove
MouseMiddle=Amove
F5 MouseRight=Amove
F6 MouseRight=Tmove
F7 MouseRight=Kmove

[MouseXYZ Config]
RealTime=1

[HotKey Console]
Shift Tab=Activate
[Console]
HISTORY=1024
HISTORYCMD=1024
LOAD=console.cmd
SAVE=console.cmd
LOG=0
LOGTIME=0
LOGFILE=log.lst
LOGKEEP=0

[sound]
SoundUse=1
SoundEngine=1
Speakers=0
Placement=0
SoundFlags.reversestereo=0
RadioFlags.Enabled=1
RadioEngine=2
MusicVolume=4
ObjectVolume=14
MusState.takeoff=1
MusState.inflight=1
MusState.crash=1
MusFlags.play=1
MasterVolume=14
Attenuation=7
SoundMode=1
SamplingRate=2
NumChannels=2
SoundExt.occlusions=0
SoundFlags.hardware=0
SoundFlags.streams=1
SoundFlags.duplex=1
SoundExt.acoustics=0
SoundExt.volumefx=0
SoundFlags.voicemgr=0
SoundFlags.static=1
VoiceVolume=14
Channels=2
SoundExt.extrender=0
SoundFlags.bugscorrect=0
SoundSetupId=9
ActivationLevel=0.02
Preemphasis=0.85
RadioLatency=0.5
AGC=1
PTTMode=1
SoundFlags.UseRadioChatter=0
SoundFlags.AutoActivation=0
RadioFlags.PTTMode=0
RadioFlags.PlayClicks=0
ActLevel=14
MicLevel=14
SoundFlags.forceEAX1=0

[rts]
;ProcessAffinityMask=1
mouseUse=2
joyUse=1
trackIRUse=1
DisableIME=0
locale=
JoyProfile=0

[rts_mouse]
SensitivityX=1.0
SensitivityY=1.0
Invert=0
SensitivityZ=1.0

[rts_joystick]
X=0 1 4 9 16 25 36 49 64 81 100 0
Y=0 1 4 9 16 25 36 49 64 81 100 0
Z=0 10 20 30 40 50 60 70 80 90 100
RZ=0 10 20 30 40 50 60 70 80 90 100 0
FF=1
U=0 10 20 30 40 50 60 70 80 90 100 0
V=0 10 20 30 40 50 60 70 80 90 100 0
1X=0 10 20 30 40 50 60 70 80 90 100 0 0
1Y=0 10 20 30 40 50 60 70 80 90 100 0 0
1Z=0 10 20 30 40 50 60 70 80 90 100 0 0
1RZ=0 10 20 30 40 50 60 70 80 90 100 0 0

[Render_DirectX]
TexQual=3
TexMipFilter=2
TexCompress=0
TexFlags.UseDither=1
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=1
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=1
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=0
TexFlags.TexCompressARBExt=1
TexFlags.TexEnvCombine4NV=0
TexFlags.TexEnvCombineDot3=0
TexFlags.DepthClampNV=0
TexFlags.SeparateSpecular=0
TexFlags.TextureShaderNV=0

HardwareShaders=0

Shadows=2
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=2
Forest=2
LandShading=3
LandDetails=2

LandGeom=2
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=4

[Render_OpenGL]
TexQual=3
TexMipFilter=2
TexCompress=0
TexFlags.UseDither=1
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=1
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=1
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=1
TexFlags.TexCompressARBExt=1

TexFlags.TexEnvCombine4NV=1
TexFlags.TexEnvCombineDot3=1
TexFlags.DepthClampNV=1
TexFlags.SeparateSpecular=1
TexFlags.TextureShaderNV=1

HardwareShaders=1

Shadows=2
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=2
Forest=2
LandShading=3
LandDetails=2

LandGeom=2
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=3
Water=2
Effects=1
ForceShaders1x=0

[QMB]
PlaneList=1
Reply With Quote
  #2  
Old 02-16-2011, 04:46 PM
Kikuchiyo Kikuchiyo is offline
Senior Member
 
Join Date: Sep 2010
Posts: 256
Default

Quote:
Originally Posted by meplay View Post
[GLPROVIDER]
GL=Opengl32.dll
If you are using an ati card you should be using directx and not opengl for your 3d rendering.

You should have posted this in Il-2 Sturmovik, not this subforum of it anyway gl hf in Sturmovik.

Last edited by Kikuchiyo; 02-16-2011 at 04:49 PM.
Reply With Quote
  #3  
Old 02-16-2011, 05:30 PM
meplay meplay is offline
Senior Member
 
Join Date: Sep 2010
Posts: 253
Default

oops thought i was lol, cos i keep jumping between forums, thanks il give it a wirl
Reply With Quote
  #4  
Old 02-16-2011, 05:46 PM
Novotny Novotny is offline
Approved Member
 
Join Date: Oct 2007
Location: Belfast, Northern Ireland
Posts: 354
Default

Why would you use Direct X instead of OpenGL with an ATI card?
Reply With Quote
  #5  
Old 02-16-2011, 06:02 PM
SEE SEE is offline
Approved Member
 
Join Date: Oct 2009
Posts: 1,677
Default

I use OpenGL with ATI. For ATI I set anystring with suffix NV to 0.
Reply With Quote
  #6  
Old 02-16-2011, 06:04 PM
meplay meplay is offline
Senior Member
 
Join Date: Sep 2010
Posts: 253
Default

ok ta , il change it
Reply With Quote
  #7  
Old 02-16-2011, 08:43 PM
=PF=Coastie =PF=Coastie is offline
Member
 
Join Date: Oct 2007
Posts: 72
Default

Quote:
Originally Posted by Kikuchiyo View Post
If you are using an ati card you should be using directx and not opengl for your 3d rendering.

You should have posted this in Il-2 Sturmovik, not this subforum of it anyway gl hf in Sturmovik.

LOL, now thats a classic! Why would anyone ever think that?
Reply With Quote
  #8  
Old 02-16-2011, 10:06 PM
Kikuchiyo Kikuchiyo is offline
Senior Member
 
Join Date: Sep 2010
Posts: 256
Default

Quote:
Originally Posted by =PF=Coastie View Post
LOL, now thats a classic! Why would anyone ever think that?
Look it up. It's a well known issue with ATI cards. They don't run Opengl well. If it runs fine for you awesome. At any rate I assumed he was on here because he was having graphic issues and I listed the most common problem with ATI cards.
Reply With Quote
  #9  
Old 02-16-2011, 10:37 PM
SEE SEE is offline
Approved Member
 
Join Date: Oct 2009
Posts: 1,677
Default

The following settings were posted by another member (sorry can't remember who for credit). It tallys with the recommended settings that I have seen for ATI cards but set the screen width/height to suit your monitor



[window]
width=1920
height=1080
ColourBits=32
DepthBits=24
StencilBits=8
ChangeScreenRes=1
FullScreen=1
DrawIfNotFocused=0
EnableResize=0
EnableClose=1
SaveAspect=0
Use3Renders=0

[Render_OpenGL]
TexQual=3
TexMipFilter=3
TexCompress=0
TexFlags.UseDither=0 (Solved, only needed for 16-bit color)
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=0 (Solved, only needed for StencilBits=0)
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=0
TexFlags.UseVertexArrays=1 (Solved, now works with ATI)
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1 (Solved, now works with ATI)
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=1
TexFlags.TexCompressARBExt=0

TexFlags.TexEnvCombine4NV=0
TexFlags.TexEnvCombineDot3=1
TexFlags.DepthClampNV=0
TexFlags.SeparateSpecular=1
TexFlags.TextureShaderNV=0

HardwareShaders=1

Shadows=2
Specular=3
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=2
Forest=3
LandShading=3
LandDetails=2

LandGeom=3
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=17
Water=2
Effects=1 (Solved, = 2 not optimized)
ForceShaders1x=0

PolygonOffsetFactor=-0.0625
PolygonOffsetUnits=-3.0
Reply With Quote
  #10  
Old 02-16-2011, 11:07 PM
Novotny Novotny is offline
Approved Member
 
Join Date: Oct 2007
Location: Belfast, Northern Ireland
Posts: 354
Default

rofl - Coastie, who wrote many guides to setting up IL-2 for graphics cards, has just been told by some non-entity to 'look it up'.

Son, shut the hell up if you don't know what you're talking about or who you're talking to.

Edit:: Oh, and, welcome to the forum. Careful, some of us bite.

More Edit:: I'm being a w****r. Sorry to K for being rude, but you are wrong with your advice.

Last edited by KG26_Alpha; 02-17-2011 at 08:40 AM. Reason: Foul languge
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:41 PM.

Based on a design by: Miner Skinz.com

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 2007 1C Company. All rights reserved.