1C Home   |   Register   |   Today Posts   |   Members   |   UserCP   |   Calendar   |   Search   |   FAQ

Go Back   Official 1C Company forum > 1C Publishing > Off-Road Drive

Off-Road Drive Off-Road Drive delivers a true-to-life, off-road, extreme racing experience.

Reply
 
Thread Tools Display Modes
  #1  
Old 08-04-2012, 06:26 PM
GMC4x4z71 GMC4x4z71 is offline
Junior Member
 
Join Date: Aug 2012
Posts: 1
Default Lag with decent computer?

Hello everybody. I recently purchased Off-Road Drive from Steam and have noticed quite a bit of a lag. my PC specs are
AMD Phenom x4 995 3.20 GHz
4GB DDR3 RAM (Corsiar)
Gigabyte GA-MA785GMT-UD2H Mobo
ATI Radion 5800 - 1GB
and a 1TB HDD (5900RPM.. SATA)

video card driver is up to date. tried turning settings down and still lags.
I have more than the recommended specs are. my friend has this game with a PC with a bit worse specs and can run without any lag.
thanks everybody!
Reply With Quote
  #2  
Old 01-01-2013, 08:32 PM
Roast7 Roast7 is offline
Junior Member
 
Join Date: Jan 2013
Posts: 1
Default

the same happens to me
Reply With Quote
  #3  
Old 01-22-2013, 08:23 PM
xtremenirvana xtremenirvana is offline
Junior Member
 
Join Date: Jan 2013
Location: Indiana
Posts: 1
Default

our laptop has the same issue

intel core I7
Intel extreme graphics gpu (not sure the stats)
4g ddr3
1tb HD.

Have to turn the settings all the way down and the resolution all the way down.

now my desktop runs with the settings all the way up at the highest res.
intel quad core black edition 3.1 ghz
gtx 560 TI 1g GPU
4g corsair hardcore gaming ram
1tb hd.

The stats arent really all that different, my desktop is even running twin monitors on one GPU and I can play a GPU demanding game and watch a movie on the other screen with zero lag.

anyone have any idea why the laptop has the lag and my desktop doesnt?
Reply With Quote
  #4  
Old 05-05-2013, 07:17 PM
WASP2145X WASP2145X is offline
Junior Member
 
Join Date: May 2013
Location: United Kingdom
Posts: 3
Exclamation CPU 4/6Core Multi Threading

Hi Off-roaders

The game Lag would usually be due to your GPU but if you have a CPU with 4 or 6 Cores this might be causing your game lag, read all the following to learn more..

My PC is:
AMD Phenom 2 X6 1055t 3.3ghz Gladiator (true Physical 6 Core CPU)
AMD/ATI Radeon HD 7770 2gb GHZ-Edition GPU
RealTek 7.1 Soundcard
16gb Ram

I brought this game recently on Steam and I also have game lag, I previously thought it was my GPU but after thorough investigation, I found out that it was because I have a 6 core CPU and this game is not designed for modern Multicore or Multi threading, you may all be having the same sort of problem.

If the Developers were to make a Multicore and Multi Threading patch for the Retail and STEAM version then the game would probably work much better..

Hopefully the Developers see this and Act upon it and Hopefully it reassures you that your computers are as perfect as you want..

Last edited by WASP2145X; 05-05-2013 at 07:33 PM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:55 AM.

Based on a design by: Miner Skinz.com

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright © 2007 1C Company. All rights reserved.