1C Home   |   Register   |   Today Posts   |   Members   |   UserCP   |   Calendar   |   Search   |   FAQ

Go Back   Official 1C Company forum > 1C Publishing > IL-2 Sturmovik: Cliffs of Dover

IL-2 Sturmovik: Cliffs of Dover Latest instalment in the acclaimed IL-2 Sturmovik series from award-winning developer 1C: Maddox Games.

Reply
 
Thread Tools Display Modes
  #1  
Old 06-30-2012, 12:45 PM
jf1981 jf1981 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 334
Default Jotstick delay (still)

Hello

I'm struggling with the very same issue, tried resinstalling usb driver and lot of other things.
It's like the in game sticker has 5 refresh per second, and it's just a little bit behind the real movements. It has the speed of old movie into the game which itself runs well.
I even could move the sticker fully left very quickly than only when I reach the mimit would the ingame sticker follow and reach in a spit of a second later.
That's hard to cope with fast moving targets in such a situation.

Good job last patch. Not bad after all, and I noted that ambiant occlusion makes a very big drop in fps. (I have a nvidia 560).

Regards

J-F
Reply With Quote
  #2  
Old 06-30-2012, 01:45 PM
Warhound Warhound is offline
Senior Member
 
Join Date: Mar 2008
Posts: 228
Default

In the CLOD controlls menu, what are the sensitivity sliders set to for your axis?
At 0.00 sensitivity the output ingame will match your inputs 100%, and thus react faster but also be more jerky.
At 1.00 there will be a delay, which smooths out spikes.

I also guess your joystick reacts normally in the windows control panel and other games? If not the problem most likely isn't CLOD.

Had a similar issue years ago with LFS where my steeringwheel lagged and stuttered ingame. Turned out if was because the USB controller couldn't handle the wheel, USB-headset and other gear all at once.
Removing the headset fixed it in my case. So try unplugging all other USB gear and then test every port with just the jostick connected.

As a final effort, if the rest doesn't work, you could try upping the USB polling rate. Some devices don't like it though, so it's up to you if you want to try this.
Can slowly up the polling rate from 125hz to 1000hz and see what it does.
http://www.techpowerup.com/forums/sh...d.php?t=106653

If you have a monitor with high inut lag, an older computer that struggles with CLOD and a joystick with say 10ms lag they might combine to give the delay you describe too.
Then it's a case of finding the culprit and replacing it.
So if you can, test the joystick on another computer ,test it on your computer with a different monitor, test another joystick with your computer, etc etc untill you can pinpoint the culprit.
Cause can be something as silly as a front USB-jack having a bad connection, one of your USB controllers being faulty, ...
Could be anything really and the only way to find out is testing ,testing and more testing.
Reply With Quote
  #3  
Old 06-30-2012, 03:05 PM
jf1981 jf1981 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 334
Default

Hi

I tried changing back to zero on sensitivity with no gain.
I tried to move the stick it to other available ports, no difference. It actually is alone on its usb port, I have only a mouse attached to another port.
I would say 125 Hz of default polling rate is more than enought.

I have this actually : youtube video
Reply With Quote
  #4  
Old 06-30-2012, 03:06 PM
droz droz is offline
Senior Member
 
Join Date: Sep 2009
Posts: 127
Default

I actually get a delay when I pull the trigger, something close to a half second. I also, sometimes, get my weapon stuck in firing mode, and I have the press the trigger to make it stop. Using a G940. Have no issues with any other game. Any ideas?
Reply With Quote
  #5  
Old 06-30-2012, 03:29 PM
David198502's Avatar
David198502 David198502 is offline
Approved Member
 
Join Date: Dec 2009
Location: Austria
Posts: 1,535
Default

Quote:
Originally Posted by jf1981 View Post
Hi

I tried changing back to zero on sensitivity with no gain.
I tried to move the stick it to other available ports, no difference. It actually is alone on its usb port, I have only a mouse attached to another port.
I would say 125 Hz of default polling rate is more than enought.

I have this actually : youtube video
to a certain extent, everybody has this i think, and its definitely clod's fault.besides the lag, the animated ingame stick acts jerky,and so do the controls...
__________________
Reply With Quote
  #6  
Old 06-30-2012, 03:38 PM
jf1981 jf1981 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 334
Default

It's only related to Clod, windows 's controller windows looks perfectly smooth & accurate, so do the other flight sim I do have, x-plane.

This issue prevents from very tight & dynamic maneuvers & firing which used to be the standard of good pilots.

I hope either one will find what's wrong of the game will be corrected if that's the problem.

On me I tried so many things, not sure no idea left.
Reply With Quote
  #7  
Old 06-30-2012, 03:40 PM
FG28_Kodiak FG28_Kodiak is offline
Senior Member
 
Join Date: Dec 2009
Location: Swabia->Bavaria->Germany
Posts: 884
Default

I don't have this problem, no input lag at all.
Reply With Quote
  #8  
Old 06-30-2012, 03:49 PM
David198502's Avatar
David198502 David198502 is offline
Approved Member
 
Join Date: Dec 2009
Location: Austria
Posts: 1,535
Default

for me its there, but not as bad as in the video above, but one can still feel it...and many people reported this already
__________________
Reply With Quote
  #9  
Old 06-30-2012, 03:53 PM
FG28_Kodiak FG28_Kodiak is offline
Senior Member
 
Join Date: Dec 2009
Location: Swabia->Bavaria->Germany
Posts: 884
Default

I've tested it, but i don't feel any lag, also in external view i move the joystick, and the ailerons etc. they react without delay.
Reply With Quote
  #10  
Old 06-30-2012, 03:57 PM
David198502's Avatar
David198502 David198502 is offline
Approved Member
 
Join Date: Dec 2009
Location: Austria
Posts: 1,535
Default

lucky you!

is your joystick animation smooth as well?
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:49 AM.

Based on a design by: Miner Skinz.com

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 2007 1C Company. All rights reserved.