1C Home   |   Register   |   Today Posts   |   Members   |   UserCP   |   Calendar   |   Search   |   FAQ

Go Back   Official 1C Company forum > 1C Publishing > IL-2 Sturmovik > Daidalos Team discussions

Reply
 
Thread Tools Display Modes
  #1  
Old 12-01-2017, 03:31 PM
Tolwyn Tolwyn is offline
Approved Member
 
Join Date: Apr 2010
Posts: 208
Default Icon Detail in Coop (mp_dotrange)

Doesn't seem to be working correctly in 4.13.4.

If I am the server in a coop, and I type in the console:

Quote:
mp_dotrange FRIENDLY COLOR 5.0 DOT 15 RANGE 5.0 TYPE 5.0 ID 5.0 NAME 5.0 ALTICON 3.0 ALTSYMBOL · ALTCOLOR 7
mp_dotrange FOE COLOR 5.0 DOT 15 RANGE 5.0 TYPE 5.0 ID 5.0 NAME 5.0 ALTICON 3.0 ALTSYMBOL + ALTCOLOR 5
I'm not seeing a change in ALTSYMBOL or its color.

Also, I have a question about the icon file in the ./user/<your pilot> folder.
What takes priority? The console or aliases in the RCU or this file?

Why the change?
Reply With Quote
  #2  
Old 12-30-2017, 07:18 PM
wheelsup_cavu's Avatar
wheelsup_cavu wheelsup_cavu is offline
Approved Member
 
Join Date: Jan 2009
Location: Riverside County, California
Posts: 264
Default

I thought in multiplayer games the server, be it another Player or Dedicated Server, dictated what icons were used in online Play and not each individual Player?


Wheels
Reply With Quote
  #3  
Old 01-15-2018, 04:02 PM
Tolwyn Tolwyn is offline
Approved Member
 
Join Date: Apr 2010
Posts: 208
Default

Right. I'm the server.
And it still doesn't work.
Reply With Quote
  #4  
Old 03-16-2018, 04:46 AM
wheelsup_cavu's Avatar
wheelsup_cavu wheelsup_cavu is offline
Approved Member
 
Join Date: Jan 2009
Location: Riverside County, California
Posts: 264
Default

Sorry for misreading your original post. I am having my own issues with the tod command so I feel your frustration. Hope you are able to figure it out since now I too want to know why it isn't working.


Wheels
Reply With Quote
  #5  
Old 03-29-2018, 04:40 PM
wheelsup_cavu's Avatar
wheelsup_cavu wheelsup_cavu is offline
Approved Member
 
Join Date: Jan 2009
Location: Riverside County, California
Posts: 264
Default

Something that came to mind because of my tod command issue. Is the host machine making the changes and not the client or are all the machines ignoring the change?

With my tod console command script the host machine accepts the time change and does it but it is not transferring to the client machines. I am wondering if you are seeing a similar issue with your attempt to change the icons.


Wheels
Reply With Quote
  #6  
Old 03-30-2018, 03:54 PM
Tolwyn Tolwyn is offline
Approved Member
 
Join Date: Apr 2010
Posts: 208
Default

The icon command change works just fine.
It's the ALTICON, ALTSYMBOL, and ALTCOLOR aren't being recognized (even for the server).



Quote:
Originally Posted by wheelsup_cavu View Post
Something that came to mind because of my tod command issue. Is the host machine making the changes and not the client or are all the machines ignoring the change?

With my tod console command script the host machine accepts the time change and does it but it is not transferring to the client machines. I am wondering if you are seeing a similar issue with your attempt to change the icons.


Wheels
Reply With Quote
  #7  
Old 03-30-2018, 04:56 PM
wheelsup_cavu's Avatar
wheelsup_cavu wheelsup_cavu is offline
Approved Member
 
Join Date: Jan 2009
Location: Riverside County, California
Posts: 264
Default

When I read your original example it seems that you have things backwards? According to the v4.11 Guide the old style Icons need to have a smaller value in the "Type" value for new Icons for it to work.

Additional icon options (from the v4.11 guide.)
Three more options were added for mp_dotrange command: ALTICON, ALTCOLOR, ALTSYMBOL.
  • ALTICON sets the maximum distance when the icon will be shown.
  • ALTCOLOR sets the color of the icon.
  • ALTSYMBOL sets the one character symbol which will be shown as icon.
These settings only kick in when old style icons are not shown, i.e. when distance of COLOR, TYPE, NAME, ID and RANGE are smaller than the distance to the aircraft.

Example:
mp_dotrange FRIENDLY DOT 25.0 COLOR 0.1 RANGE 0.1 TYPE 1.0 ID 0.1 NAME 0.1 ALTICON 2.5 ALTSYMBOL + ALTCOLOR 3
This will display a symbol "+" above the aircraft between 1.0 and 2.5 km in color 3 (green).

In their example "Type" is 1.0 and ALTICON is 2.5. (Only numbers that match their example)
In your example "Type" is 5.0 and ALTICON is 3.0. Reverse the numbers and see if that works for you?

Edit:
I tested it on the 352nd dogfight server and found that everything except the DOT value needs to be smaller than the ALTICON value or the ALTICON symbol will not show. Once one of those values is triggered the ALTICON symbol disappears in favor of the other options.

Grab4894 shows three plus signs but grab4896 shows just two plus signs and the Range and Type ID for the other aircraft. In grab4896 the Range and Type ID's have taken precedence for the closest aircraft.


Wheels
Attached Images
File Type: jpg grab4894.jpg (795.4 KB, 2 views)
File Type: jpg grab4896.jpg (735.9 KB, 2 views)

Last edited by wheelsup_cavu; 03-30-2018 at 07:43 PM. Reason: Got it to work on our dogfight server
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:59 AM.

Based on a design by: Miner Skinz.com

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright © 2007 1C Company. All rights reserved.