1C Home   |   Register   |   Today Posts   |   Members   |   UserCP   |   Calendar   |   Search   |   FAQ

Go Back   Official 1C Company forum > 1C Publishing > IL-2 Sturmovik: Cliffs of Dover > Technical threads > Performance threads

Performance threads All discussions about CoD performnce

Reply
 
Thread Tools Display Modes
  #1  
Old 04-01-2011, 10:55 AM
machoo
Guest
 
Posts: n/a
Default With tweaks it's better

Last night it was a mess , now with the config tweaks found here the fps are much improved. Still flying over land is a problem - which is kinda a big problem being the core of the sim ( lol ) but flying over water it's smooth and fast. My system is pretty dated too ( 8800GT , 4GB DDR , 2.8ghz )
Reply With Quote
  #2  
Old 04-01-2011, 06:16 PM
mmitch10 mmitch10 is offline
Junior Member
 
Join Date: Oct 2007
Posts: 14
Default

My system is similar to yours, but none of the tweaks I've tried seem to have improved it. Which ones did you find to be effective?
Reply With Quote
  #3  
Old 04-01-2011, 07:39 PM
Bulau Bulau is offline
Junior Member
 
Join Date: Oct 2007
Location: Ontario, Canada
Posts: 16
Default

What resolution? And is this with XP = DX9 or Win7 = DX10?
Reply With Quote
  #4  
Old 04-01-2011, 08:43 PM
machoo
Guest
 
Posts: n/a
Default

Ok , first of all I have the settings at 'Performance' in Nvidia control panel the rest i'll just copy and paste. Here is a video example of the fps ( allow for compression )

conf.ini

[window]
DepthBits =24
StencilBits=8
DrawIfNotFocused=0
SaveAspect=0
Render=D3D10_0
width=1280
height=720
ColourBits=32
FullScreen=1
ChangeScreenRes=1

[NET]
speed=100000
localPort=27015
serverName=My Server
serverDescription=IL-2 Sturmovik: Cliffs of Dover
serverInfo1=
serverInfo2=
serverInfo3=
serverInfo4=
VAC=1
maxPlayers=16
socksEnable=0
socksHost=
socksPort=1080
socksUser=
socksPwd=

[Console]
IP=20001
UseStartLog=1
WRAP=1
PAUSE=1
HISTORY=1024
HISTORYCMD=1024
PAGE=20
LOG=0
LOGTIME=0
LOAD=console.cmd
SAVE=console.cmd
LOGFILE=log.txt
LOGKEEP=0

[rts]
tickLen=30
ProcessAffinityMask=15
maxTimerTicksInRealTick=20
; 0 - not use, 1 - show cursor and not capture, 2 - not show cursor, and capture
mouseUse=2
; 0 - not use, 1 - use if hardware exist
joyUse=1
; 0 - not use, 1 - use if hardware exist
trackIRUse=1
DisableIME=0
culture=en-GB

[rts_mouse]
SensitivityX=1.0
SensitivityY=1.0
SensitivityZ=1.0
Invert=0
SwapButtons = 0

[rts_joystick]
FF=1

[core]
DynamicalLights=0 (default =1)
VisibilityDistance=2 (default =4)
ShadowMapSize=3 (default =5)
RandSeed = 0
TexQual=3
TexFlags.PolygonStipple=0
Shadows=1
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
LandShading=2
LandDetails=1
Sky=3
Forest=0
VisibilityDistance=3
LandGeom=2
DrawCollisions=1
Water=-1
Effects=2
EffFlags.Light=1
EffFlags.SpriteRender=0
Grass=-1
CordEffect=1
UseFog=0
UseLandCube=1
UseLandConnectedObject=1
LinearObjectManager=1
Roads=-1
Sun=1
Clouds=1
EffFlags.LightSpritesProj=1
ShadowMapSize=5
TexFlags.AsyncLoad=1
TexFlags.ShowTexture=0
SimpleMesh.SWTransform=0
SimpleMesh.QuadTreeClip=1
SimpleMesh.InstancingHW=1
EffFlags.LightContextSprites=1
CloudsFlags.Detailed=1
TexFlags.CreateHDR=1
Decals=1
EffFlags.SWLight=0
TexFlags.CockpitOnePass=0
MegaTexture=0
TexFlags.Reflection=0
RenderTargetQual=3
MSAA=4
MeshStatics=1
MeshStaticsDetail=1
SimpleMesh.QTNoCompose=0
MeshFirstLod=0
MeshShowLod=0
SpawnHumans=0
TexFlags.FastTransparency=1

[sound]
SoundUse=1
DebugSound=0
SoundEngine=1
Speakers=1
Placement=0
SoundFlags.reversestereo=0
RadioFlags.Enabled=1
RadioEngine=2
MusicVolume=14
ObjectVolume=7
MusState.takeoff=1
MusState.inflight=1
MusState.crash=1
MusFlags.play=1
MasterVolume=14
Attenuation=7
SoundMode=0
SamplingRate=0
NumChannels=2
SoundExt.occlusions=1
SoundFlags.hardware=1
SoundFlags.streams=1
SoundFlags.duplex=1
SoundExt.acoustics=1
SoundExt.volumefx=1
SoundFlags.voicemgr=1
SoundFlags.static=1
VoiceVolume=8
Channels=1
SoundFlags.bugscorrect=0
SoundExt.extrender=0
SoundSetupId=8
ActivationLevel=0.02
Preemphasis=0.8
RadioLatency=0.5
AGC=1
PTTMode=1
RadioFlags.PTTMode=0
RadioFlags.PlayClicks=1
ActLevel=9
MicLevel=10
SoundFlags.UseRadioChatter=0
SoundFlags.AutoActivation=0
SoundFlags.forceEAX1=0
speakers=1

Last edited by machoo; 04-01-2011 at 08:48 PM.
Reply With Quote
  #5  
Old 04-01-2011, 08:50 PM
machoo
Guest
 
Posts: n/a
Default

I changed the resolution to 1280x720 , but run 8x FSAA. Also run model detail , decal , shadows and effects at High. The rest low or off.
Reply With Quote
  #6  
Old 04-01-2011, 11:47 PM
No601_Merlin No601_Merlin is offline
Member
 
Join Date: Aug 2010
Posts: 50
Default

machoo I have changed the ProcessAffinityMask=15 to 14 that allows windows to use core 0, leaving core 1,2,3 for CoD. Its posted elsewhere that it offers a small improvement.
Reply With Quote
  #7  
Old 04-01-2011, 11:57 PM
Koyan Koyan is offline
Member
 
Join Date: Jan 2011
Location: A bridge too far
Posts: 52
Default

@machoo

Below [core] you should not add those 3, they are already in the list (little lower) you only need to change the values.
Reply With Quote
  #8  
Old 04-02-2011, 01:29 AM
seiseki seiseki is offline
Member
 
Join Date: Nov 2010
Posts: 51
Default

I have similar specs, will try your config!
Thanks! ~S

What OS?
I'm running Win7 64bit.
Reply With Quote
  #9  
Old 04-02-2011, 01:35 AM
machoo
Guest
 
Posts: n/a
Default

I'm the same , win7 64bit. Also you can tweak the graphics from the windows control panel , then click 'hardware and sound' then 'nvidia control panel' Then click the 'Manage 3D settings' tab on the top left. Click on 'Program settings' then add the 'Launcher.exe' file from within the Cliffs of Dover install location. You can then do all kinds of enhancements.
Reply With Quote
  #10  
Old 04-02-2011, 02:08 AM
seiseki seiseki is offline
Member
 
Join Date: Nov 2010
Posts: 51
Default

I already set everything to performance..

Just a question are you using trackIR?

The framerates I get are just horrible..
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:27 PM.

Based on a design by: Miner Skinz.com

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright © 2007 1C Company. All rights reserved.