1C Home   |   Register   |   Today Posts   |   Members   |   UserCP   |   Calendar   |   Search   |   FAQ

Go Back   Official 1C Company forum > 1C Publishing > IL-2 Sturmovik

IL-2 Sturmovik The famous combat flight simulator.

Reply
 
Thread Tools Display Modes
  #1  
Old 11-14-2012, 10:32 PM
illegalBeagle illegalBeagle is offline
Junior Member
 
Join Date: Jun 2008
Posts: 20
Default Game crashing: OpenGL message “lost connection”

Since I got my GTX260 a couple of years ago I would occasionally get a crash right at the start of a game when host hits fly. It's happened 3 times in the last 2 days, kinda annoying when playing mostly co-ops. The crash message directs me to a Nvidia site with this message:



I have seen this Event Log Message:

The NVIDIA OpenGL driver lost connection with the display driver due to exceeding the Windows Time-Out limit and is unable to continue.

The application must close.

What does it mean?

If you received this message from an application (on a pop up message or in the Event Log), the application was unable to continue rendering because the Microsoft Windows imposed time limit (TDR) was exceeded. This is normally the case when the workload sent to the Graphics Card is greater than what the graphics card can process in the normal timeout of two seconds.

You can find more information in this page:

http://msdn.microsoft.com/en-us/wind.../gg487368.aspx

How can this be fixed?

Two possible solutions to try would be:

Reduce the graphics workload if possible, such as rendering to a lower resolution or with less detail.
Increase the timeout to allow more time to complete the really tough rendering parts. Microsoft provides the information on how to modify the Windows Registry to achieve this.


The card is superior to the one I had, but the game settings are the same I think, so I have not tried reducing game settings. I've tried various graphics card drivers with no success. Does anyone know a solution to this problem?
Here is my conf.ini:

[il2]
title=Il2-Sturmovik Forgotten Battles
hotkeys=HotKey game

[window]
width=1920
height=1080
ColourBits=32
DepthBits=24
StencilBits=8
ChangeScreenRes=1
FullScreen=1
DrawIfNotFocused=0
EnableResize=0
EnableClose=1
SaveAspect=0
Use3Renders=0

[GLPROVIDER]
GL=Opengl32.dll

[GLPROVIDERS]
Open GL=Opengl32.dll
DirectX=dx8wrap.dll

[NET]
speed=8000
routeChannels=0
serverChannels=11
localPort=21000
remotePort=21000
SkinDownload=1
serverName=Beagle
serverDescription=
remoteHost=
localHost=203.100.212.101
socksHost=
checkServerTimeSpeed=1
checkClientTimeSpeed=0
remoteHost_000=66.225.104.64:21000
remoteHost_001=204.80.88.43.21040
remoteHost_002=

[DeviceLink]
port=1711
host=192.168.2.3


[MaxLag]
farMaxLagTime=10.0
nearMaxLagTime=2.0
cheaterWarningDelay=5.0
cheaterWarningNum=-1

[chat]
region=(dx=0.75208336,dy=0.16018519,x=0.12708333,y =0.001851851
adr0=ALL
adr1=MY_ARMY
msg6=check\u00206
msg5=\u002050mm\u0020@\u002015m\u0020lol
msg1=DSC\u0020TERMINATE
msg3=\u0020<nextmap
msg2=<tl
msg0=gg
msg8=thanks\u0020host\u0020gg
msg4=<teams
msg9=DSC\u0020MAP\u002011



[game]
Arcade=0
HighGore=1
mapPadX=0.61944443
mapPadY=0.44444445
viewSet=36


Intro=0
NoSubTitles=0
NoChatter=1
SubTitlesLines=3
NoHudLog=0
NoLensFlare=1
iconTypes=3
eventlog=eventlog.lst
eventlogkeep=0
3dgunners=0
ClearCache=0


[HotKey game]
PrintScreen=ScreenShot
P=pause
Pause=pause

[HotKey gui]
Escape=activate

[HookViewFly Config]
timeFirstStep=2.0
deltaZ=10.0

[HookView]
MouseLeft=Len

[HookView Config]
AzimutSpeed=0.1
TangageSpeed=0.1
LenSpeed=1.0
MinLen=1.0
DefaultLen=20.0
MaxLen=3000.0
Speed=6

[HotKey builder]
MouseLeft=objectMove
MouseRight=popupmenu
Enter=freeView
Shift MouseLeft=worldZoom
Alt MouseLeft=select+
Alt MouseRight=select-
Alt Ctrl=unselect
PageDown=change+
PageUp=change-
End=change++
Home=change--
Ctrl MouseLeft=insert+
Insert=insert+
NumPad-0=insert+
F=fill
Ctrl MouseRight=delete+
NumPad.=delete+
Delete=delete+
Backspace=cursor
Tab=cursor
F10=land
F11=onLand
NumPad-=normalLand
NumPad+=toLand
NumPad-5=resetAngles
NumPad-8=resetTangage90
NumPad-7=stepAzimut-5
NumPad-4=stepAzimut-15
NumPad-1=stepAzimut-30
NumPad-9=stepAzimut5
NumPad-6=stepAzimut15
NumPad-3=stepAzimut30

[MouseXYZ]
F1=SpeedSlow
F2=SpeedNormal
F3=SpeedFast
MouseRight=XYmove
F4 MouseRight=Zmove
MouseMiddle=Amove
F5 MouseRight=Amove
F6 MouseRight=Tmove
F7 MouseRight=Kmove

[MouseXYZ Config]
RealTime=1

[HotKey Console]
Shift Tab=Activate
[Console]
HISTORY=1024
HISTORYCMD=1024
LOAD=console.cmd
SAVE=console.cmd
LOG=1
LOGTIME=1
LOGFILE=log
LOGKEEP=0

[sound]
SoundUse=1
SoundEngine=1
Speakers=1
Placement=0
SoundFlags.reversestereo=0
RadioFlags.Enabled=1
RadioEngine=2
MusicVolume=0
ObjectVolume=7
MusState.takeoff=0
MusState.inflight=0
MusState.crash=0
MusFlags.play=0
MasterVolume=5
Attenuation=7
SoundMode=1
SamplingRate=2
NumChannels=0
SoundExt.occlusions=0
SoundFlags.hardware=1
SoundFlags.streams=1
SoundFlags.duplex=1
SoundExt.acoustics=0
SoundExt.volumefx=0
SoundFlags.voicemgr=0
SoundFlags.static=1
VoiceVolume=0
Channels=2
SoundExt.extrender=0
SoundFlags.bugscorrect=0
SoundSetupId=8
ActivationLevel=0.02
Preemphasis=0.85
RadioLatency=0.5
AGC=1
PTTMode=1
SoundFlags.UseRadioChatter=0
SoundFlags.AutoActivation=0
RadioFlags.PTTMode=1
RadioFlags.PlayClicks=0
ActLevel=0
MicLevel=0
SoundFlags.forceEAX1=0

[rts]
ProcessAffinityMask=8
mouseUse=2
joyUse=1
trackIRUse=1
DisableIME=0
locale=us
JoyProfile=0

[rts_mouse]
SensitivityX=2.0
SensitivityY=2.0
Invert=0
SensitivityZ=1.0

[rts_joystick]
X=0 1 4 9 16 25 36 49 64 81 100 0
Y=0 1 4 9 16 25 36 49 64 81 100 0
Z=0 10 20 30 40 50 60 70 80 90 100
RZ=0 10 20 30 40 50 60 70 80 90 100 0
FF=0
U=0 10 20 30 40 50 60 70 80 90 100 0
V=0 10 20 30 40 50 60 70 80 90 100 0
1X=0 100 100 100 100 100 100 100 100 100 100 0 0
1Y=0 100 100 100 100 100 100 100 100 100 100 0 0
1Z=0 100 100 100 100 100 100 100 100 100 100 0 0
1RX=1 0 4 9 16 25 36 49 64 81 100 0 0
1RZ=2 5 9 14 20 29 39 52 66 82 100 0 0
1U=0 0 3 5 8 12 17 23 31 41 52 0 0
1V=0 100 100 100 100 100 100 100 100 100 100 0 0
1X1=0 5 7 10 15 20 27 34 43 54 65 0 0
1Y1=0 100 100 100 100 100 100 100 100 100 100 0 0
1RZ1=0 100 100 100 100 100 100 100 100 100 100 0 0
1U1=0 100 100 100 100 100 100 100 100 100 100 0
1V1=0 100 100 100 100 100 100 100 100 100 100 0
1X2=0 100 100 100 100 100 100 100 100 100 100 0 0
1Y2=0 100 100 100 100 100 100 100 100 100 100 0 0
1U2=0 100 100 100 100 100 100 100 100 100 100 0
1V2=0 100 100 100 100 100 100 100 100 100 100 0
1Z2=0 100 100 100 100 100 100 100 100 100 100 0 0
1Z1=0 100 100 100 100 100 100 100 100 100 100 0
1RY=0 100 100 100 100 100 100 100 100 100 100 0 0


[Render_OpenGL]
TexQual=3
TexMipFilter=3
TexCompress=0
TexFlags.UseDither=1
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=1
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=1
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=1
TexFlags.TexCompressARBExt=1

TexFlags.TexEnvCombine4NV=1
TexFlags.TexEnvCombineDot3=1
TexFlags.DepthClampNV=1
TexFlags.SeparateSpecular=1
TexFlags.TextureShaderNV=1

HardwareShaders=1

Shadows=2
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=1
Forest=3
LandShading=3
LandDetails=2
LandGeom=3
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=36
Water=0
Effects=1
ForceShaders1x=0

PolygonOffsetFactor=-0.15
PolygonOffsetUnits=-3.0
Forest=4


[Render_DirectX]
TexMipFilter=3
TexCompress=0
TexFlags.UseDither=0
TexFlags.PolygonStipple=0
TexFlags.UseVertexArrays=1
TexFlags.TexEnvCombine4NV=0
TexFlags.TexEnvCombineDot3=0
TexFlags.DepthClampNV=0
TexFlags.SeparateSpecular=0
TexFlags.TextureShaderNV=0
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=0
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=0
TexFlags.TexCompressARBExt=0
ForceShaders1x=0
PolygonOffsetFactor=-0.15
PolygonOffsetUnits=-3.0
VideoSetupId=1
[DGen]
GroundIntensity=Normal

Last edited by illegalBeagle; 11-14-2012 at 10:34 PM.
Reply With Quote
  #2  
Old 11-15-2012, 07:54 PM
KG26_Alpha's Avatar
KG26_Alpha KG26_Alpha is offline
Super Moderator
 
Join Date: Jan 2008
Location: London
Posts: 2,523
Default

Hi

Did the last DX entries get cut off when copy/pasting or are they missing in the conf.ini ?

If they are in the conf.ini or you have a back up proceed with the following:

A. Make sure the conf.ini resolution is the same as the monitors resolution, so if the monitors running a resolution of 1920x1080 as in your conf.ini
[window]
width=1920
height=1080

This is correct.

B. Make sure you clean the old driver registry entries and old driver files from your system before installing new drivers.

You can use a driver cleaner utility like this one.

http://www.guru3d.com/files_get/guru...taller),7.html

Run it in safe mode.

http://www.bleepingcomputer.com/tuto...-in-safe-mode/

Clean all video/gpu related drivers and if you had an ATI card in there before run it to clean those entries as well.

Once its clean boot up normally and install the recommended driver and settings.

Only after doing this should you pursue any of the other fixes related to Timeout Detection and Recovery (TDR)
__________________



Last edited by KG26_Alpha; 11-15-2012 at 08:06 PM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:37 PM.

Based on a design by: Miner Skinz.com

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright © 2007 1C Company. All rights reserved.